How to Install Language Mentor

Submit to FacebookSubmit to Google PlusSubmit to Twitter

iPhone or iPad:

Android:

Note: Language Mentor requires Android OS 8.0 (Oreo) or higher.

 

 

 

.